Mandelbrot Madness!

Version 2.0 -- Command Overview: The Tools Menu

[Return to Index] [Return to Command Overview]

The Main Window Command Menu

Tools Menu The Tools menu is the descendent of the Command menu which first appeared in Mandelbrot Madness JAVA! version 3.1. The Command menu allowed you to use most of the command-line utilities through a simple GUI connection, a conscession primarily for our friends with Macs (who didn't (at the time) have a command line) and for others who may be command-line impaired for any reason. Many of the old Command menu items have been consolidated, however, so a more general "Tools" name has been adopted. All the old functionality of the Command menu can still be found here, however.

File Converter: Over the years, MM! has collected quite a zoo of different parameter file formats. Each has different advantages and disadvantages; the newer formats each add new features over the old ones, but are generally less backward compatible. Rather than leaving old files around to suffer bit rot, I've included a file converter utility to help you convert from one format to another. When you choose this option, you will first get an Open dialog box where you can choose any MM! supported parameter file. Once you click the Open button, a Save dialog will open, where you can specify the converted file name and format. To select the format, choose the format in the "Save as type" drop down box. Then specify the location and name of the file to create. The original file will remain unmodified and a new file will be created with the name, location, and format you specify. Note that if you attempt to create a new file with an extension different from the default for the chosen format, the default extension will be appended to the end of the file name. Also note that certain advanced features of MM! are not supported by older formats, and some of this additional information may be lost. For more about the differences between parameter file formats, check out the Technical Information and Command Line Utilities pages.

PaletteBuilder: This is a companion application written especially to accompany MM! This nifty little applet lets you create and modify Jasc PAL palette files, which MM! uses to define external color palettes. (If you are familiar with Jasc's Paint Shop Pro application, the dialog may look remotely familiar.) Since PaletteBuilder accompanies the MM! distribution, it is always available. To find out more about PaletteBuilder, follow this link.

My Image Editor: This option will launch your favorite image editor so you can further tweak images generated by MM! You can copy images to the image editor through the Copy Image item under the Edit Menu, or by saving the image to an image file and loading it into the editor. By default, MM! searches the Windows registry to find out what program can (ideally) edit or (as a fall-back) open PNG files, MM!'s default image format. Sometimes, however, MM! may fail to find a program that can open these files, or the program chosen may only display images but not let you edit them. In these cases, you can always manually specify your favorite image editor through the Options Menu. If no program can be found that can open PNG files, this option will be disabled.

[Return to Index] [Return to Command Overview]

© Copyright 2007, Jeffrey T. Darlington. All rights reserved.