Mandelbrot Madness!

Version 2.0 -- Command Overview: The File Menu

[Return to Index] [Return to Command Overview]

The Main Window File Menu

File Menu The File menu in the main window contains some very important commands for managing files and image windows and information. When you first start MM!, you may notice that some of these options are disabled; they will become enabled as soon as you render your first image, and become disabled later if there are no longer any open image windows. Let's look at each item:

New...: This option opens the Render Dialog to get you started on creating a new Mandelbrot or Julia set image. In this dialog, you can set the image parameters and choose the color palette you want to use. Note that you have the same basic functionality built right in to the Render Toolbar, with the exception of choosing preset views. (Preset views are only available in the Render Dialog.) This menu item is equivalent to clicking the New button on the Main Toolbar.

Open...: This option lets us open a MM! parameter file. MM! lets you save all the image parameters necessary to recreate any given image, including the color palette. This information is stored in one of three formats: a small text file with an .MMJ extension with a corresponding palette (.PAL) file; a single compact binary file that contains both the parameters and palette, which we affectionately call a "MOB" (MandelObject) file; or a new XML-based format called MM XML that can include parameter and palette information, user comments, and even prerendered image data. Using any of these formats lets you store image information and reload it later (although the different formats may have different options associated with them). Use this Open command to open a saved .MMJ, .MOB, or MM XML file.

While you can find a more in-depth discussion of MMJ vs. MOB vs. MM XML files on the Technical Information Page, you should note that MMJ is more backward compatible with older versions of Mandelbrot Madness JAVA!, our sister Java-based program. MOB will only work with MMJ! versions 3.1 or higher, while versions of MMJ files go all the way back to version 2.0. There are slight differences between 2.0 and 3.0+ MMJ files. MM XML files are totally new to this version of MM! and are currnetly unsupported by MMJ! You can convert back and forth between all these formats through the Command Line Utilities or the Tools Menu.

Save Sub-Menu: This option lets you save a rendered image either as a parameter file (which can be reopened in MM! and rendered again) or as an image file (which cannot be reopened in MM! but can be opened in any image editor). As mentioned above, there are three primary parameter file formats: MMJ (potentially along with a PAL palette file), MOB, and MM XML files. MM! supports the following image formats: PNGs, Windows Bitmaps, TIFFs, Compuserve GIFs, and JPEGs. Check the links for information about each format. Please note that while JPEGs and GIFs are supported (a capability granted to us by .NET), we don't recommend their use, as their default implementation provides very poor image quality. In both of these cases, the format you chose to save the parameters or image in can be selected through the "Save as type" drop-down in the save dialog box.

You can save a rendered image in several different formats; usually, you will want to save the image graphic to a PNG, while saving the parameter information to a MOB or MMJ so you can recreate it later. There are two buttons on the Main Toolbar that produce the same results as these menu items. These options are disabled if there are no image windows currently open.

Close: This option closes the currently active image window. By default, MM! will prompt you to save the image's parameters to a parameter file if you haven't already done so. (You can change this behavior under the Options Menu.) This option is disabled if there are no image windows currently open.

Rerender...: This option lets you recreate the currently active image and make any modifications you wish, like increasing the resolution or number of iterations, or changing the color palette. This is useful because you can do quick renders of an image at low resolutions and iterations to get a quick glance at what it will look like, then you can rerender it to produce a better quality image. This item has the same effect as clicking the Rerender button on the Main Toolbar. This option is disabled if there are no image windows currently open.

Print...: This option lets you print the active image to your printer. Please Note: Printing support in Java-based versions of MM! has always been poor because of poor implementations of the printing interface in Java virtual machines. Printing support is much better in this version of MM! but still not great. This is mostly because my priority has always been image generation, not printing, so my intended target is generally an image file and not paper. So don't expect miracles! YOU HAVE BEEN WARNED! :) This item has the same effect as clicking the Print button on the Main Toolbar. This option is disabled if there are no image windows currently open.

Info...: This option displays a small dialog box showing you all the parameters for the active image, including the name of its palette and how long it took to render. This is useful when you have a lot of image windows and you want to see a particular one's parameters. Usually, the palette name is not displayed anywhere else, so this is especially important if you want to reuse a palette. This item has the same effect as clicking the Info button on the Main Toolbar. This option is disabled if there are no image windows currently open.

Exit: This will close the MM! application. It will also close all open image windows and, by default, ask you if you want to save each one before it closes. (You can change this behavior under the Options Menu.) When you choose this menu item, you will see a dialog box that asks if you are sure you want to exit, just in case you hit it accidentally.

[Return to Index] [Return to Command Overview]

© Copyright 2007, Jeffrey T. Darlington. All rights reserved.