Mandelbrot Madness!

Version 2.0 -- Command Overview: The Main Toolbar

[Return to Index] [Return to Command Overview]

The Main Toolbar

Main Toolbar

Introduced in MMJ! 4.0, this handy toolbar gives you quick and easy access to many of the important operations you may need when rendering images. These buttons activate the same commands as the various menus.

New: This button opens the Render Dialog to get you started on creating a new Mandelbrot or Julia set image. In this dialog, you can set the image parameters and choose the color palette you want to use. Note that you have the same basic functionality built right in to the Render Toolbar, with the exception of choosing preset views. (Preset views are only available in the Render Dialog.) This button is equivalent to the New menu item button in the File Menu.

Open: This button lets us open a MM! parameter file. MM! lets you save all the image parameters necessary to recreate any given image, including the color palette. This information is stored in one of three formats: a small text file with an .MMJ extension with a corresponding palette (.PAL) file; a single compact binary file that contains both the parameters and palette, which we affectionately call a "MOB" (MandelObject) file; or a new XML-based format called MM XML that can include parameter and palette information, user comments, and even prerendered image data. Using any of these formats lets you store image information and reload it later (although the different formats may have different options associated with them). Use this Open command to open a saved .MMJ, .MOB, or MM XML file. This button is equivalent to the Open menu item button in the File Menu.

While you can find a more in-depth discussion of MMJ vs. MOB vs. MM XML files on the Technical Information Page, you should note that MMJ is more backward compatible with older versions of Mandelbrot Madness JAVA!, our sister Java-based program. MOB will only work with MMJ! versions 3.1 or higher, while versions of MMJ files go all the way back to version 2.0. There are slight differences between 2.0 and 3.0+ MMJ files. MM XML files are totally new to this version of MM! and are currnetly unsupported by MMJ! You can convert back and forth between all these formats through the Command Line Utilities or the Tools Menu.

Save: These buttons let you save a rendered image either as a parameter file (which can be reopened in MM! and rendered again) or as an image file (which cannot be reopened in MM! but can be opened in any image editor). As mentioned above, there are three primary parameter file formats: MMJ (potentially along with a PAL palette file), MOB, and MM XML files. MM! supports the following image formats: PNGs, Windows Bitmaps, TIFFs, Compuserve GIFs, and JPEGs. Check the links for information about each format. Please note that while JPEGs and GIFs are supported (a capability granted to us by .NET), we don't recommend their use, as their default implementation provides very poor image quality. In both of these cases, the format you chose to save the parameters or image in can be selected through the "Save as type" drop-down in the save dialog box.

You can save a rendered image in several different formats; usually, you will want to save the image graphic to a PNG, while saving the parameter information to a MOB or MMJ so you can recreate it later. These buttons are equivalent to the same options in the File Menu. These buttons are disabled if there are no image windows currently open.

Rerender: This button lets you recreate the currently active image and make any modifications you wish, like increasing the resolution or iterations, or changing the color palette. This is useful, so you can do quick renders of an image at low resolutions and iterations to get a quick glance at what it will look like, then you can rerender it to produce a better quality image. This button has the same effect as choosing the Rerender menu item in the File Menu. This button is disabled if there are no image windows currently open.

Print: This option lets you print the active image to your printer. Please Note: Printing support in Java-based versions of MM! has always been poor because of poor implementations of the printing interface in Java virtual machines. Printing support is much better in this version of MM! but still not great. This is mostly because my priority has always been image generation, not printing, so my intended target is generally an image file and not paper. So don't expect miracles! YOU HAVE BEEN WARNED! :) This button has the same effect as choosing the Print menu item in the File Menu. This button is disabled if there are no image windows currently open.

Info: This option displays a small dialog box showing you all the parameters for the active image, including the name of its palette and how long it took to render. This is useful when you have a lot of image windows and you want to see a particular one's parameters. Usually, the palette name is not displayed anywhere else, so this is especially important if you want to reuse a palette. This button has the same effect as choosing the Info menu item on the File Menu. This option is disabled if there are no image windows currently open.

Copy Parameters: This button copies the parameters of the currently selected image to the system clipboard, where it can be pasted into any form of text document. This button has the same effect as choosing the Copy Parameters menu item in the Edit Menu. This option is disabled if there are no image windows currently open.

Copy Image: This button copies the rendered image data of the currently selected image to the system clipboard, where it can be pasted into any form application that accepts image data. This button has the same effect as choosing the Copy Image menu item in the Edit Menu. This option is disabled if there are no image windows currently open.

Edit Comments: This button lets you edit the comments associated with the currently selected image. If you save this image in MM XML format, these comments will be saved along with the parameter information. This button has the same effect as choosing the Edit Comments menu item in the Edit Menu. This option is disabled if there are no image windows currently open.

File Converter: This button lets you convert between various formats of MM! parameter files. To learn more about the file converter, check out the Tools Menu.

Launch PaletteBuilder: This button launches PaletteBuilder, one of MM!'s helper applications. This small application was written especially to accompany MM! This nifty little applet lets you create and modify Jasc PAL palette files, which MM! uses to define external color palettes. (If you are familiar with Jasc's Paint Shop Pro application, the dialog may look remotely familiar.) Since PaletteBuilder accompanies the MM! distribution, it is always available. To find out more about PaletteBuilder, follow this link.

My Image Editor: This option will launch your favorite image editor so you can further tweak images generated by MM! You can copy images to the image editor through the Copy Image item under the Edit Menu, or by saving the image to an image file and loading it into the editor. By default, MM! searches the Windows registry to find out what program can (ideally) edit or (as a fall-back) open PNG files, MM!'s default image format. Sometimes, however, MM! may fail to find a program that can open these files, or the program chosen may only display images but not let you edit them. In these cases, you can always manually specify your favorite image editor through the Options Menu. If no program can be found that can open PNG files, this option will be disabled.

Help Contents: This button launches the online help you're reading now.

[Return to Index] [Return to Command Overview]

© Copyright 2007, Jeffrey T. Darlington. All rights reserved.