Mandelbrot Madness!

Version 2.0 -- Command Overview: The Image Window

[Return to Index] [Return to Command Overview]

The Image Window

The Image Window Once you've rendered an image in MM!, an image window is produced. Each image has its own window, which can be manipulated individually. Image windows can be managed through the Window menu. When the currently active window changes, the parameters associated with that image (including its palette) are copied to the Render toolbar.

By default, if you close an image window (or choose Close All from the Window menu), you will be prompted to save the parameters for a given image if you haven't done so already. You can disable this prompt from the Options dialog.

With an image window open, try moving your mouse pointer over the image. You will notice that the status bar at the bottom of the main window (assuming you haven't disabled it) will change to a set of numbers. These tell you the x and y coordinates of the cursor's position in the image. These will be useful for deriving Mandelbrot and Julia set images later.

The Context (or Pop-Up) Menu

When you right-click (or, if you have your mouse set up for left-hand use, left-click) the image, a context menu will appear with a number of options associated with the current image. Most of these options are also available from the File and Edit menus, although one significant function can only be found here.

Render Julia Set at this point: If your current image is a Mandelbrot image, you can click this option to create a Julia set image based on the current x and y coordinates. The values will be filled in on the Render dialog and/or Render toolbar, where you can then specify the resolution, number of iterations, and the color palette. (This works similar to the Rerender function.) This option will be disabled if you bring the context menu up over a Julia set image.

Rerender...: This option lets you recreate the currently active image and make any modifications you wish, like increasing the resolution or number of iterations, or changing the color palette. This is useful because you can do quick renders of an image at low resolutions and iterations to get a quick glance at what it will look like, then you can rerender it to produce a better quality image. This item has the same effect as clicking the Rerender button on the Main Toolbar or the Rerender menu item in the File menu.

Copy Parameters: This option copies the parameters of the currently active image window to your system clipboard. This data is in text format and consists of a small header, followed by the image window name, the numeric parameters (X and Y values, resolution, iterations), and the name of the image's palette. This is extremely useful when documenting on a Web page the images you create with MM! Once pasted into other applications, you can edit and format the text as you wish.

Copy Image: This option copies the raw graphical image data to your system clipboard so it can be pasted into other applications. This is useful if you wish to touch up the image in your favorite image editor, but don't want to bother with saving and reloading files. This option is disabled if there are no image windows currently open.

Save Parameters...: This option lets you save a rendered image either as a parameter file which can be reopened in MM! and rendered again. There are three primary parameter file formats: MMJ (potentially along with a PAL palette file), MOB, and MM XML files. Using either of these formats lets you store image information and reload it later.

While you can find a more in-depth discussion of MMJ vs. MOB vs. MM XML files on the Technical Information Page, you should note that MMJ are more backward compatible with older versions of Mandelbrot Madness JAVA!, our sister Java-based program. MOB will only work with MMJ! versions 3.1 or higher, while versions of MMJ files go all the way back to version 2.0. There are slight differences between 2.0 and 3.0+ MMJ files. MM XML files support all of the new options availabe in this version of MM! but aren't as backward compatible. You can convert back and forth between these formats through the Command Line Utilities or the Tools Menu.

Save Image...: This item will let you save the graphical image generated from the parameters as a standard image file. MM! supports the following image formats: PNGs, Windows Bitmaps, TIFFs, Compuserve GIFs, and JPEGs. Check the links for information about each format. Please note that while JPEGs and GIFs are supported (a capability granted to us by .NET), we don't recommend their use, as their default implementation provides very poor image quality. The format you choose to save the image in can be selected through the "Save as type" drop-down in the save dialog box.

Print...: This option lets you print the active image to your printer. Please Note: Printing support in Java-based versions of MM! has always been poor because of poor implementations of the printing interface in Java virtual machines. Printing support is much better in this version of MM! but still not great. This is mostly because my priority has always been image generation, not printing, so my intended target is generally an image file and not paper. So don't expect miracles! YOU HAVE BEEN WARNED! :) This item has the same effect as clicking the Print button on the Main Toolbar.

Info...: This option displays a small dialog box showing you all the parameters for the active image, including the name of its palette and how long it took to render. This is useful when you have a lot of image windows and you want to see a particular one's parameters. Usually, the palette name is not displayed anywhere else, so this is especially important if you want to reuse a palette. This item has the same effect as clicking the Info button on the Main Toolbar.

Close: This will close the current image window. By default, you will be prompted to save the image’s parameters if they haven't been saved already, but you can disable this feature as mentioned above.

Image Derivation: Zooming in on a Selection

There is one last command function we haven't discussed, and it just happens to be the most fun. By clicking and dragging a selection inside an image window, you can zoom in on an area of the image. When you let up on the mouse, a confirmation box will appear, asking if you want to zoom in on the selection. If you agree, the boundaries of the selection will be copied and the Render toolbar, where you can tweak any settings you want before rendering the new image. Note that if your selection is perfectly square, its boundaries will be extended until it is square. From that point on, the process is the same as rerendering an image. Image derivation works for both Mandelbrot and Julia set images.

[Return to Index] [Return to Command Overview]

© Copyright 2007, Jeffrey T. Darlington. All rights reserved.