PaletteBuilder

Version 2.0 README File

PaletteBuilder is a simple application designed to open, create, modify, and save Jasc PAL palette files. Jasc PAL files are simple text files that contain information on color palettes and were originally used to save palettes for their Paint Shop Pro application. Mandebrot Madness!, a Mandelbrot and Julia set image renderer written in Java and .NET, uses Jasc PAL files to store palette information. PaletteBuilder was designed as a helper application to accompany MM! and allow users more flexible control over building custom palettes.

Starting with this version, PaletteBuilder now has the capability to read palettes from MM! MOB and MM XML parameter files as well as Microsoft PAL palette files. However, you may not write to any of these formats; if you open a MOB, MM XML, or Microsoft PAL file and make changes to its palette, you must save the palette to a Jasc PAL file.

Starting PaletteBuilder

The easiest way to run PaletteBuilder is from within MM! On the main toolbar, click the Launch PaletteBuilder button, or from the Command menu choose Helper Apps then PaletteBuilder. PaletteBuilder will then launch. Please Note: If you open PaletteBuilder through this method and then close MM!, it will close both applications. The primary advantage of launching PaletteBuilder by this method is that it will default to the same file folder as the Palette folder setting in MM!

It is possible to run PaletteBuilder by itself without launching MM! first. Navigate through the Start menu to the program group where Mandelbrot Madness! is located and select PaletteBuilder instead of Mandelbrot Madness! The primary disadvantage to launching it this way is that it won't default to the MM! Palette folder.

[Top]

Command Overview

Here is a list of PaletteBuilder's commands:

File -> New...: Creates a new palette. When you choose this menu item, you will be presented with a dialog box that asks you to select the palette size. You may create palettes with 16 or 256 colors. PaletteBuilder will only read and write 16- and 256-color palettes. When you click the Ok button, a new, empty palette is created. Shortcut key N.

File -> Open...: Opens a palette file. This menu item will open your operating system's open file dialog box, where you can select a file to load. Only valid Jasc PAL, Microsoft PAL, or MM! MOB and MM XML files can be opened. If a file is not a valid palette file, you will be told so when PaletteBuilder tries to open it. Shortcut key O.

File -> Save: Saves the currently open file to disk. If you already have a file open, this option will let you save the current palette to the open filename without having to specify it in a dialog box. Use this to quickly save your work after making a change. This item is disabled if you created a new palette from scratch; use the Save As... item instead. Shortcut key S.

File -> Save As...: Save the current open palette to a new file name. This will open your operating system's save file dialog, where you can specify a name to save your palette to. Use this when saving a newly created palette, or if you want to save a palette opened from a file to a new file name. Note that PaletteBuilder will only write Jasc PAL files; it will not write Microsoft PAL, MM! MOB, or MM XML files. Shortcut key A.

File -> About...: Displays PaletteBuilder copyright information.

File -> Exit: Exits PaletteBuilder. If the currently open palette has not been saved, you will be prompted to do so. Shortcut key X.

All Edit menu commands can also be reached by bringing up a pop-up menu on the desired color.

Edit -> Copy Color: Copies the currently selected color to the "clipboard." Shortcut key C.

Edit -> Copy Color Range...: Allows you to copy a range of colors to the "clipboard." This will open a Copy Color Range dialog box, where you can specify the starting and ending index values for the copy. Then these colors will be copied to PaletteBuilder's internal clipboard and the copy can be pasted elsewhere into this or another palette. You can also perform this action by first selecting the starting color index with the mouse, then holding down the Control key and clicking the second index. Shortcut key K.

Edit -> Paste Color: Replaces the currently selected color with the color on the "clipboard." This is disabled if no color has been copied to the clipboard. Shortcut key V.

Edit -> Paste Color Range: Copies a range of colors from the "clipboard" into the palette. The first color on the clipboard will replace the currently selected color in the palette, and the rest of the colors will replace the colors after it. The size of the color range pasted depends on the size of the color range copied earlier. If the pasted range exceeds the size of the palette, only the colors that can be pasted will be pasted. This item is disabled if no color range has been copied to the clipboard. Shortcut key P.

Edit -> Change Color...: Change the currently selected index color to another color. This will open a Select Color dialog box, where you can specify the color to be used at this index value. You can also access this function by double-clicking the color you wish to change. Shortcut key H.

Edit -> Create Range...: Creates a blended range of colors from one index value to another. With this function, you can create a smooth transition between two colors by specifying a starting and ending index value and starting and ending colors. PaletteBuilder will then create the color range and paste it into the palette at the indexes specified. Shortcut key R.

[Top]

Shortcut Keys

Most menu commands have shortcut keys available. Shortcut keys, or "accelerator keys," allow you to perform the same function of a menu command with only a couple quick keystrokes. Hold down the Control key then press the shortcut key to activate the command.

[Top]

How Do I...?

[Top]

Known Bugs

Unfortunately, even the best of programs have "bugs." (It's just that the best of 'em don't have as many!) Here are a few of the known bugs in PB that I am working on fixing. Please do not report these; I already know about them. If you find what you think is a bug, follow these actions:

  1. Check this list for known bugs first. If you can't find it here...
  2. Mail me at jeff@gpf-comics.com and give me the following information:

I can't guarantee that I can fix all problems, especially since I don't have access to all the platforms and VMs that you can run PB on. However, I will certainly try. Now, as promised, here's that bug list:

[Top]

Version History

[Top]

Copyright and Contact Information

This program is © Copyright 2007, Jeffrey T. Darlington. All rights reserved. This program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.

You should have received a copy of the GNU General Public License along with this program; if not, write to the Free Software Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.

You can learn more about the GNU General Public License at its official web site at http://www.gnu.org/copyleft/gpl.html.

Contact Information

Official Mandelbrot Madness Web page: http://www.gpf-comics.com/dl/mandel/
(You'll find PaletteBuilder there too!)

Jeffrey T. Darlington, program author
E-Mail: jeff@gpf-comics.com
Web: http://www.gpf-comics.com/dl/mandel/

Please visit General Protection Fault at http://www.gpf-comics.com/
Thank you, and God bless us, everyone.

Last revised March 19, 2007

[Top]

[Return to Main MMJ! Help]

© Copyright 2007, Jeffrey T. Darlington. All rights reserved.